1

I'm dealing with a large plan developed by different people and it has some durations in days and some in weeks, but I'd like to unify them all in days. what is the best way to do this in MS Project 2010? I have tried to change from Options menus but it doesn't work, any clever suggestions?

1

Here is a quick way to convert all durations (hours, weeks, and/or minutes) to days; durations already in days are left unchanged.

  1. Insert a numbered Duration field (e.g. Duration1)
  2. Right-click the column and select Custom Fields
  3. Click the Formula... button and enter this formula: [Duration]
  4. Click Ok twice to return to the main screen
  5. Select the Duration1 column added in Step 1 and copy
  6. Select the Duration column and paste
1

I just had the same problem but easily fixed. I had a mix of days and weeks in the Duration column. Go to Options, Schedule - click on Duration - I changed the Duration from Weeks to Days then saved. I still had a mix BUT I redid and changed duration to weeks and saved - All durations changed to weeks. Fixed.

1

Note Rachel and Marv's solutions do not work with Summary Tasks: Duration1 column shows 0 duration for the Summary Task.

enter image description here

To resolve this, you could:

  1. Perform Rachel's solution above
  2. Hide summary tasks (Gantt Chart Format tab -> Show/Hide -> uncheck Summary Tasks)
  3. Copy the custom column Duration1
  4. Paste into Duration
  5. Unhide Summary Tasks

Now all the summary tasks, including Summary Tasks, have the new units. From there you could hide the Duration1 custom-column, and even delete it. enter image description here

Note if you copy / paste without first hiding summary tasks, this pastes the 0 value from Duration1 into Duration.

enter image description here

Also note that changing the setting in Options (File -> Options -> Schedule -> Scheduling Options for this Project -> Duration is Entered In) will modify units in Summary Tasks and the custom-column Duration1 but not the built-in column Duration. I tried saving / redoing as Chloe suggests above but I don't see that it fixes the built-in column Duration.

enter image description here

0

I don't believe you can change the way the Duration column is displayed.

But you can add a new number column, call it 'Normalised Duration' (or whatever you want) and make it display the duration you want:

  1. Add column of type Number 1
  2. Double-click on the heading and change it to whatever title you want
  3. Right-click the column and select Custom Fields
  4. Click 'Formula'
  5. In the Formula field you can enter [Duration] which will show the duration in working minutes, then just divide by the number minutes in a working day (i.e. 8x60=480 for an 8-hour day), so the formula looks like "[Duration]/480"
  6. Click Ok

Now the working day duration will be displayed in your column no matter what duration units were used in the actual Duration column.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.