I'm using Project Online and am trying to create a custom calculated column which shows me the percentage difference between my "Actual Cost" and a custom column called "Profitability".

I'm having issues with the calculations actually working, and I feel like there's a bigger issue here than just the syntax of my formula.

For reference, it is:

(([Actual Cost] / [Profitability] * 100) & "%")

After I created the column, I tried to get it to return a value and it wasn't returning anything at all, I broke it down even further to just:

[Actual Cost] / [Profitability]

Still nothing, I even went further and tried to return the value of a column:

[Actual Cost]

No dice. I then tried to do a basic calculation (11*19), and even that wasn't returning a value. I checked my project out, re-published it and checked it back in to see if it I needed to force a re-calculation and that didn't help at all.

Can anyone provide any insight? I feel like there's a background issue that I'm not seeing here, and given how limited PWA is to diagnostics I'm not too sure where I should be looking.

Thanks!

One thing I'm not clear on here is if you are checking out the project in the Web interface or in MS Project Pro. If in MS Project Pro, if you don't know, be sure to close the application down and reopen it so any changes to the ECFs come into the local work space. It doesn't dynamically load this sort of stuff. But you probably know that ...

I'd like to know how the profitability field is defined, but, that's not terribly relevant considering you've cut it down to basic math and you are not getting results.

Are you getting values on any tasks at all or just not on summary tasks? I ask because I often miss checking the right box for how to calculate for summary tasks.

I have seen it take a very long time to update when there are say 30 projects on the site. Like 30 minutes. That's projects in the 500 - 1000 row each range. Changing it several times in a row just gums things up worse.

About all I have left is to try it in MS Project Pro just to validate it's working. But again, 11*19 is pretty simple, yeah ...

Sorry I don't have more to offer.

  • Thanks for the reply Jack, my check out/check in was done via MS Project Pro. I did think it had something to do with the type (which was "Cost) but I've since created a few test columns as both "Number" and "Text" types and I'm still not getting anything. I even tried CInt() conversions to see if it was a type issue but it didn't seem so. I'm not getting any values on any task at all (this column was created at the Project level). I did think the issue could just be a delay in processing, but I checked the queue and there wasn't anything there (not sure if anything should be though..). – Junior Apr 22 '16 at 2:05
  • Bummer. Well. I'd submit a support request. Believe it or not they've been pretty responsive to mine. Project is a bit out of the normal support path, but they worked through. I'd say I'm 2.5 for 3 on solutions. This is making me think something is hung at teh SQL server level / something needs to be set / reset on the back end. We don't see all the processes of course. Please let us know what the fix ends up being. Sounds like you've done everything I would have done for sure. – JackW327 Apr 23 '16 at 21:16
  • That's the direction I was heading in.. Thanks anyway Jack. I'll keep my fingers crossed that it's something easy to fix. – Junior Apr 26 '16 at 4:48

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.