6

I'm designing an IT project sheet for my department. I have a certain methodology in mind, but i'm trying to translate it into Project's configuration.

Here's what I'd like to do:

  • I want to set max untis for each resource in my department to a % of their 8 hour day (i.e. 40% of 8 hours each day for projects, or 3.2hrs / day)
  • Then I want to manually estimate the amount of time a task will take to complete (backup accounting data - 8 hours)
  • Then I want to assign a resource to a task, and based on the estimated amount of time for that task relative to the max units (hours/day) the assigned resource can spend on that task, I want project to auto-adjust the duration and the start/finish times

I was under the impression that I could accomplish this by setting:

  • Project Work Times - m-f 8a-12p & 1p-5p (8 hours/day, 5 days a week)
  • Default Task Type - Fixed Work
  • Max units for resource - 20%
  • Manually set 'Work" column to estimated hours for task
  • Assign resource to task
  • Then 'Duration' & 'Start/Finish' columns should auto-adjust based on preset criteria

For whatever reason this seems to not be working, or possibly working in a way i'm not understanding.

For example, I indicated a task would take 8 hours, and I assigned a resource to it with max untis 40% (3.2 hours / day), but for that specific task assigned the resource's 'Units' at 100% (i.e. I want this resource to spend 100% of their 3.2 hrs/day on this task alone), and yet the duration column states 1 day, and the start/finish columns both have the same day.

Given my assumptions, I would expect the 8 hour task to be broken up into 3.2 hour increments per day based on max units% for the resource, so the duration should be 2.5 business days (8 divided by 3.2 = 2.5) and start finish should reflect that based on the defined project work week.

Does anyone know what/how I need to configure my project to accomplish this? What am I missing?

  • Despite my best efforts playing around with this, I still can't get a project setup the way I need to. For some reason Project is not respecting the Units % I'm assigning to resources. – I.T. Support Jun 21 '11 at 17:59
4

If you want the resource to spend 40% of their 8 hour day on a task you need to set their % allocation to 40% not 100%. Setting it to 100% tells Project that you want them to spend 100% of their day on that task. The % allocation value tells Project how much of their work day they can spend on the task. This relates to the resource max allocation in that if you manually allocate a resource at 100% to a task but their max allocation is set to 50% in the resource sheet they will always appear over allocated. The max allocation is how much of their day they are available for the project (i.e. the rest of the work day is taken up with some other non-project work).

If you want the same resource to work on 2 tasks on the same day then you will need to set this up differently. In this case set your resource max availability to 100% which allows Project to schedule them for the entire day. Then for each task set their allocation to 40%. This seems to work ok in 2010 but in older versions of Project, it really struggled with this and the resource always appeared over allocated.

So I think you need to do as follows:

EITHER

  • Set the max allocation to 40% in the resource sheet
  • Manually set the work column to the amount of effort needed to complete the task
  • Assign the resource to a task at the default 40%
  • Project will auto set the duration to (work * 40%)

OR

  • Set the max allocation to 100% in the resource sheet
  • Manually set the work column to the amount of effort needed to complete the task
  • Assign the resource to a task and manually change the allocation from the default 100% to 40%
  • Project will auto set the duration to (work * 40%)

Also make sure that your tasks are Auto Scheduled rather than Manually Scheduled otherwise none of this will work! The Task Mode column shows this (by default it is the 2nd column in the Gantt View).

1

Based on your write-up, you need to set the task up as fixed units, which will then allow the schedule to commit those resource up to the maximum you indicate in the resource pool. Then manually plug work hours and the duration should adjust for you. The way you had it, it still calculated duration based on the eight hours and "over allocated" your resources based on the resource pool.

1

I think you are right to set the "Work" column. I've found the way project copes with this a little shakey.

The main thing to get the work / duration calculation to work is to have the task Auto scheduled. It's still annoying that you get the green box tip with every change but it does work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy