1

When I use auto-leveling in MS Project to schedule my tasks, some tasks are often split without visible reason. So the plan becomes not too real, like following:

TaskA.. [day break] TaskB TaskC TaskD ..TaskA 

As you understand this plan is not very good because of loosing the context of the task.
I see that the tasks could be scheduled without splitting or with much less splitting. E.g. it would be okay if it build the following schedule:

TaskA.. [day break] ..TaskA TaskB TaskC TaskD 

Is there a way to deny MS Project to split tasks while auto-leveleling or at least to control such behavior?

  • scheduling is not an exact science. resource leveling is a tool to quickly get an idea of limitations, ie not enough resources to do the work in the same timeframe. – user7433 Nov 25 '13 at 17:59
3

I'm guessing you have turned off the Leveling option "Leveling can create splits in remaining work"?
You can also control splitting on a task by task basis (instead of all or nothing), by inserting the field Leveling Can Split in a task view and setting the field to "no" for tasks that you do not wish the leveling command to split.

3

I think that David's response was a bit harsh... but I understand why. The built-in leveling tool in MS Project is greatly misunderstood, and if not used in a very controlled manner, it can wreak havoc in your project schedule.

One very important thing to remember about the built-in leveling tool is that it is only capable of resolving resource over allocations by doing one of two things:

  • It can delay a task to remove an over allocation.
  • It can split a task to remove an over allocation.

There are other methods of resolving resource over allocations in a project, such as...

  • Assigning another available resource to help perform a task.
  • Re-assigning a task to another available resource.
  • Reducing an assigned resource's utilization on a task.
  • Increasing an assigned resource's availability.

...but MS Project's built-in leveling tool is not capable of doing those things for you. If you want to use one of those techniques, then you will need to do them manually.

Having said that, if you DO choose to use the built-in resource leveling feature, I recommend that you manually level one resource at a time... and DO NOT run the feature automatically. To set the resource leveling tool to run manually, rather than automatically, do the following:

  • Click the 'Resource' tab to display the 'Resource' ribbon in MS Project (assuming that you are using Project 2010 or Project 2013).
  • Click the 'Leveling Options' button in the 'Level' section of the 'Resource' ribbon.
  • In the 'Resource Leveling' dialog box, select the 'Manual' option at the top (rather than 'Automatic'), the click the 'OK' button.

If you are going to level one resource at a time using the resource leveling tool, then it is also CRUCIAL that you DESELECT the 'Clear leveling values before leveling' option in the 'Resource Leveling dialog box.

To level one resource at a time using the built-in resource leveling tool, do the following:

  • Identify a resource in the project that is the most over allocated or the most critical, using views such as the 'Resource Graph' or the 'Resource Usage'.
  • Apply the 'Resource Usage' view and select the name of the over allocated resource.
  • Click the 'Resource' tab to display the 'Resource' ribbon, then click the 'Level Resource' button in the 'Level' section of the ribbon.
  • In the 'Level Resources' dialog box, ensure that the desired resource is selected in the list, then click the 'Level Now' button.
  • Review the results of the leveling operation using the 'Resource Usage' view or the 'Leveling Gantt' view; if the results are acceptable, then move on to the next over allocated resource, otherwise undo / clear the leveling operation and try another approach to resolve that resource's over allocation.

Getting back to the task splitting issue, there is an option that you can use to control whether MS Project is allowed to split tasks. To select or deselect the option, do the following:

  • Click the 'Resource' tab to display the 'Resource' ribbon in MS Project (assuming that you are using Project 2010 or Project 2013).
  • Click the 'Leveling Options' button in the 'Level' section of the 'Resource' ribbon.
  • In the 'Resource Leveling' dialog box, select or deselect the 'Leveling can create splits in remaining work' option, the click the 'OK' button.

Good luck!

-- tz

2

The solution is very simple: DO NOT AUTO-LEVEL YOUR SCHEDULE! At best, the auto-level functionality could be used just to see what schedule issues you have that the tool finds. Analyze what it pushed and pulled to give you a clue where you have a scheduling constraint that you need to resolve manually. Other than that, never push that button.

1

I fixed mine by removing the option Leveling can adjust individual assignments on a task. And of course, remove create splits in remaining work.

Now, the only way that work is split from over allocation is when the resource only works week days (In comparison to the other resources who work the regular calendar you have set up)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.